FIX PROBLEM : Your server is running PHP version 5.1.6 but WordPress 3.2.1 requires at least 5.2.4.

Nu prentru toti este stiut faptul ca pentru a instala sau a face upgrade-ul la o versiune mai noua de 3.2, este necesar ca pe sa fie instalata o versiune mai noua de 5.2.4.

Daca pe server este instala o versiune de PHP mai veche de 5.2.4, la instalarea versiunii de WordPress 3.2.1, va aparea eroarea / mesajul: "Your server is running PHP version 5.1.6 but WordPress 3.2.1 requires at least 5.2.4".
Problema poate fi rezolvata foarte simplu, prin upgrade de PHP, insa inainte de a face acest lucru trebuie avute in vedere cateva lucruri. In primul rand, upgrade-ul de PHP este exclus pe un share hosting. Ca sa puteti face upgrade-ul trebuie sa aveti acces de administrator pe server (server dedicat sau VPS). In a doilea rand, inainte de upgrade trebuie sa sa documentati si sa fiti atenti ca noua versiune de PHP sa nu dea erori altor site-uri hostate pe acel server.

Pentru ca este sistemul de operare cel mai utilizat pentru web servere (agreart si de / WHM) o sa va aratam cum se poate face upgrade-ul la PHP 5.2.10 pe CentOS 5.x 32-bit.

Upgrade PHP 5.1.x la 5.2.x pe CentOS 5.x 32-bit

1. Verificam ce pachete / module PHP sunt instalate (ex. php-mcrypt) pe langa packetul standard. Daca acestea exista, vor trebui sterse sau actuzlizate.

Verificam pachetele instalate:

rpm -qa | grep php

old_php_version

2. Adaugam noi arhive pentru , necesare upgrade-ului de versiune PHP.

nano /etc/yum.repos.d/CentOS-Testing.repo

In fisierul nou creat (CentOS-Testing.repo) se vor adauga liniile de mai jos (copy / paste):

[c5-testing]
name=CentOS-5 Testing
baseurl=http://dev.centos.org/centos/$releasever/testing/$basearch/
enabled=1
gpgcheck=1
gpgkey=http://dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing
includepkgs=php*

Ctrl + X pentru a salva fisierul CentOS-Testing.repo.

3. Update PHP via yum :

yum update

4. Restart / httpd :

service httpd restart

Dupa restart httpd verificati versiunea si pachetele instalate:

new_php_version

Verificati daca exista erori ale modulelor / pachetelor:

php -v

PHP Upgrade / CentOS 32-bit (i386).

FIX PROBLEM : Your server is running PHP version 5.1.6 but WordPress 3.2.1 requires at least 5.2.4.

About the author

Stealth L.P.

Fondator si editor Stealth Settings, din 2006 pana in prezent.
Experienta pe sistemele de operare Linux (in special CentOS), Mac OS X , Windows XP > Windows 10 si WordPress (CMS).

Leave a Comment

This site uses Akismet to reduce spam. Learn how your comment data is processed.